if you get an error when not using EN-US locale

Jan 21, 2015 at 9:06 AM
hello
i've just donwload the last version of PAL and i get an error when locale are not en-US ( i'm using french locale):
An error occurred on...
$global:currentThread.CurrentCulture = $usenglishLocales
Au caractère C:\Program Files\PAL\PAL\PAL.ps1:285 : 5 + $global:currentThread.CurrentCulture = $usenglishLocales + ~~~~~~~~~~~~~~~~~~~~~
Impossible d’extraire la variable « $global:currentThread », car elle n’a pas été définie.
to be able to use PAL, i've just add the following in the "Set-EnglishLocales" function ( line 284 of pal.ps1):
$global:currentThread = [System.Threading.Thread]::CurrentThread
maybe you can add this in the official version?

Regards,
Erwan
Feb 2, 2015 at 11:01 PM
Ji, I added the line at the end of the function but getting £

Your locale is set to: French (France)
Your locale is not English. PAL unfortunately must be running under an English locale. Setting it to English-US.
C:\Users........\Documents\PAL Reports\AppFabric-EXT1PPROOPFFB02-CacheCounterError0_PAL.htm


romulf wrote:
hello
i've just donwload the last version of PAL and i get an error when locale are not en-US ( i'm using french locale):
An error occurred on...
$global:currentThread.CurrentCulture = $usenglishLocales
Au caractère C:\Program Files\PAL\PAL\PAL.ps1:285 : 5 + $global:currentThread.CurrentCulture = $usenglishLocales + ~~~~~~~~~~~~~~~~~~~~~
Impossible d’extraire la variable « $global:currentThread », car elle n’a pas été définie.
to be able to use PAL, i've just add the following in the "Set-EnglishLocales" function ( line 284 of pal.ps1):
$global:currentThread = [System.Threading.Thread]::CurrentThread
maybe you can add this in the official version?

Regards,
Erwan
Feb 10, 2015 at 5:35 PM
Hello
you just need to add it at the begining of the function.
Jul 8, 2015 at 9:04 AM
Thank you for the solution. PAL works after I make the proposed change.

+1 for changing it in the next version of PAL.
Aug 11, 2015 at 1:39 PM
Hello,
I have more one question: my server is running Windows Server 2012 R2 Portuguese Brazil and I am gotting errors.

"Error processing "C:\Analise de sistema\Performance Counter.blg"

Report Generated at: 2015.08.11-09:08:40 PALv2

Overall progress... Status: Calculating counter statistics [very CPU intensive]..., PAL 2.7.4 Progress: 65%... Calculating counter statistics [very CPU intensive]...,

An error occurred on...
$iPercentComplete = ConvertToDataType $(($iIndexOfJobs / $iTotalJobs) * 100) 'integer'
At C:\Program Files\PAL\PAL\PAL.ps1:2289 char:49 + $iPercentComplete = ConvertToDataType $(($iIndexOfJobs / $iTotalJobs) * ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Attempted to divide by zero.


SCRIPT ARGUMENTS:
Log: C:\Analise de sistema\Performance Counter.blg
ThresholdFile: C:\Program Files\PAL\PAL\SystemOverview.xml
AnalysisInterval: AUTO
IsOutputHtml: $True
IsOutputXml: $False
HtmlOutputFileName: [LogFileName]_PAL_ANALYSIS_[DateTimeStamp].htm
XmlOutputFileName: [LogFileName]_PAL_ANALYSIS_[DateTimeStamp].xml
OutputDir: [My Documents]\PAL Reports
AllCounterStats: $True
NumberOfThreads: 4
IsLowPriority: $True
DisplayReport: True


Please contact the PAL tool team with this error by posting it to pal.codeplex.com. Thank you!"

Could anybody help me?
Oct 18, 2015 at 10:27 AM
+1 for changing it in the next version of PAL.
May 23 at 4:14 PM
I tried this; and although no errors and seemingly working ok, in the reports I got warnings on free disk space less than 5% while using a non-english regional settings.
Switched back to english and no warnings (and there actual disk space is plenty; 40+% ) using the same .blg file to make report.

Also, the frontend/palwizard.exe displays only the hours 01-12 and not 13-23 so you need AM/PM settings to differentiate time of day