3

Closed

Internet Explorer process remains active after PAL

description

Hi. I have scheduled tasks to daily run PAL in several servers. The problem I have is the Internet Explorer process stills active in the end of the PAL process and every day the scheduled task run a new process of IE is opened.
Closed Oct 3, 2013 at 6:10 PM by ClintH
Use -DisplayReport $False

comments

JonnyG wrote Jul 19, 2010 at 2:53 PM

Hi

This sounds like a feature that would be quite easy to add as a switch to the command line parameters. In the mean time if you are using the Powershell version on PAL you could just comment out this piece of code in "function main" just add a hash # before "OpenHtmlReport" and you should get reports generated but not opened in IE.

JonnyG

JonnyG wrote Jul 19, 2010 at 3:01 PM

Hi,

Sounds like a handy feature that should be quite easy to add as an additional switch to the command line parameters. In the mean time you should be able to achieve the desired results by commenting out the line "OpenHtmlReport" using a hash #. This call the the function OpenHtmlReport which invokes you default browser to view the report you can find the call to it located in the function main towards the bottom on the pal.ps1 file

JonnyG

web1701 wrote Feb 22, 2013 at 8:14 PM

I know this thread is old but I wanted to say I am also running scheduled perfmon/PAL tasks and this solved the issue of IE running under the login executing PAL.ps1 for me as well. Thanks!

ClintH wrote Feb 22, 2013 at 9:18 PM

Yes, this would be relatively easy to implement. I'll try to get it added soon. Thanks for the reminder.

ClintH wrote Oct 3, 2013 at 6:09 PM

ClintH wrote Oct 3, 2013 at 6:09 PM

Use $DisplayReport=$False as a parameter to PAL.ps1. I haven't exposed this in the PAL Wizard user interface yet, but I plan to do so.