Pal V 2.0 Alpha Error -

Nov 2, 2009 at 9:26 PM

I receive the below error when trying to run a log file through the script.  I received this error both when running the sampleperfmonlog file and one that I had in house.  I assume I am doing something wrong so any input would be appreciated.

 

WARNING: Please post errors or problems with this tool to the PAL web site located at http://www.codeplex.com/PAL with
the following error message and a brief description of what you were trying to do. Thank you.
Could not find a part of the path 'C:\Users\clinth\Documents\~MyDocs\~Projects\PAL_PS\temp.txt'.
At C:\data\pal2\PAL.ps1:752 char:21
+     $sCounterPath >> <<<<  'C:\Users\clinth\Documents\~MyDocs\~Projects\PAL_PS\temp.txt'
    + CategoryInfo          : OpenError: (:) [], DirectoryNotFoundException
    + FullyQualifiedErrorId : FileOpenFailure

Nov 2, 2009 at 9:43 PM

Sorry, it looks like I should have probably posted this in issue tracker.  Let me know if you want me to re-post it there.

Coordinator
Nov 3, 2009 at 4:12 AM

Either is fine. Most people post their errors here in the Discussions area anyway. :-)

This error is completely my fault. I forgot to remove the debugging files I was using during testing and debugging. I have removed these references and updated the zip file just now. Try downloading it again and try again. Thanks for trying it!

Nov 3, 2009 at 5:50 PM

Thanks, it is working now.  Now onto the next thing.  In the memory leak detection area the report shows Process(_Total)\Private Bytes as leaking memory.  In PAL 1 it looks like that counter does not create an entry in the report.  If I compare the reports side by side it actually shows the processes that are leaking memory which are not show in the 2.0 report.  Hopefully that makes sense.

On a side note do you want these types of things questioned or are you just mainly looking for issues when running the script?

Thanks again for all your hard work!