Analysis Interval in PAL 2.7.5 Will Not Use Interval Other Than Auto

Dec 2, 2015 at 3:02 PM
Even though I chose the 10 min. interval for analysis (the script shows -Interval "600") my PAL reports still default to auto for time intervals. These same logs run under PAL 2.4 provided an expected result of 10 minutes when this value was set.

Is anyone else experiencing this? Does anyone have a solution?

Donnie
Dec 2, 2015 at 5:02 PM
Donnie,
600 is the number of seconds in 10 min.
Richard
Dec 2, 2015 at 9:57 PM
Richard,

I know that 600 seconds is 10 minutes - and that is the desired operation that I'm looking for.

What I was saying is that even though I select 10 minutes - and the script appears to have the correct setting for the -Interval variable, the HTML report continues to default to 'Auto' time segments.

It appears that even if you select something other than 'Auto', the powershell script disregards the -Interval variable.

Thank you for your response - I am hoping someone can confirm the same behavior or advise if I am doing something wrong with the new version of the tool.

Donnie
Dec 2, 2015 at 10:21 PM
Ok, I can understand that. It sounded like when you selected the 10 min interval that you were expecting something different. Just to remind me, what is the auto interval? I'm using an older version of the PAL tool and don't have a problem with the interval. I get what I'm expecting.

Alternatively, you could open the scripts and see what the code is doing.

Let us know what you find out with this. I agree that 10 min. is entirely too long of an interval for performance tuning reports.

Richard
Dec 2, 2015 at 10:58 PM
The Auto interval takes the log file and reports it back in intervals often much longer than 10 minutes. The script correctly reports an interval of 600 seconds, however this is not what I get in the HTML report. I've opened the PAL.ps1 but still trying to decipher it. Until fixed, I'll be sticking with PAL 2.4.

If I figure it out, I'll post back.
Feb 26 at 7:26 PM
I made two changes to the v2.7.5 PAL.ps1 that seemed to fix this for me:
  1. I formally declared the $Interval parameter on the opening param statement (making it a variable).
param($Log='SamplePerfmonLog.blg',$ThresholdFile="QuickSystemOverview.xml",$AnalysisInterval='AUTO',$Interval='AUTO',$IsOutputHtml=$True,$IsOutputXml=$False,$HtmlOutputFileName="[LogFileName]_PAL_[DateTimeStamp].htm",$XmlOutputFileName="[LogFileName]_PAL_[DateTimeStamp].xml",$OutputDir="[My Documents]\PAL Reports",$AllCounterStats=$False,$BeginTime=$null,$EndTime=$null,[System.Int32] $NumberOfThreads=1,$IsLowPriority=$False,$DisplayReport=$True)
  1. I set the $AnalysisInterval variable to the $Interval variable in the ProcessArgs function.
    If ($AnalysisInterval -is [System.String])
    {
        If ($($AnalysisInterval.IndexOf("AUTO", [StringComparison]::OrdinalIgnoreCase)) -gt 0)
        {
            $AnalysisInterval = 'AUTO'
        }
    }
    
    $AnalysisInterval = $Interval
    
    [void] $ProcessedArgs.Add('AnalysisInterval',$AnalysisInterval)

    [void] $OriginalArgs.Add('HtmlOutputFileName',$HtmlOutputFileName)
I made these changes based on the fact that the wizard appears to always pass "AUTO" for the value of $AnalysisInterval (not because I could debug/follow the logic of the PAL.ps1 file :) )

Let me know if these code clips are clear, if not I can email the updated PAL.ps1

Regards,

-t-
Feb 27 at 10:22 PM
Todd -

Could you email (or post) the updated PAL.ps1 file? You should probably let Clint know as well so that your fix can be rolled up into the next version of PAL (2.7.6?).

Thanks!