Syntax error generated by PAL v2.0 Beta 1

Jun 15, 2010 at 5:54 PM

Thought a quick try of the beta for v2 would be worthwhile However, it generates the following powershell output:

C:\temp>Powershell "C:\Program Files\PAL\PAL v2.0 Beta 1\PAL.ps1" -Log 'C:\temp\TS Performance monitoring_000003.blg' -ThresholdFile 'C:\Program Files\PAL\PAL v2.0 Beta 1\SystemOverview.xml' -Interval 'AUTO' -IsOutputHtml $True -HtmlOutputFileName '[LogFileName]_PAL_ANALYSIS_[DateTimeStamp].htm' -IsOutputXml $False -XmlOutputFileName '[LogFileName]_PAL_ANALYSIS_[DateTimeStamp].xml' -AllCounterStats $False -OutputDir 'C:\temp\PalReports' -NumberOfProcessors 2 -ThreeGBSwitch $False -SixtyFourBit $False -TotalMemory 14

The term 'C:\Program' is not recognized as a cmdlet, function, operable program, or script file. Verify the term and try again.

At line:1 char:11+ C:\Program  <<<< Files\PAL\PAL v2.0 Beta 1\PAL.ps1 -Log 'C:\temp\TS Performance monitoring_000003.blg' -ThresholdFile 'C:\Program Files\PAL\PAL v2.0 Beta 1\SystemOverview.xml' -Interval 'AUTO' -IsOutputHtml $True -HtmlOutputFileName '[LogFileName]_PAL_ANALYSIS_[DateTimeStamp].htm' -IsOutputXml $False -XmlOutputFileName '[LogFileName]_PAL_ANALYSIS_[DateTimeStamp].xml' -AllCounterStats $False  -OutputDir 'C:\temp\PalReports' -NumberOfProcessors 2 -ThreeGBSwitch $False -SixtyFourBit $False -TotalMemory 14

This is really for info only. I'll go back to version 1.3.6.

Coordinator
Jun 21, 2010 at 11:40 PM

My fault. In my haste to get Beta 1 out for TechEd 2010, I didn't properly test it and accidentally introduced this bug. I fixed it in PAL v2.0 Beta 1.1. Please try downloading it again, install, and retry. http://pal.codeplex.com.

Thank you,

Jun 23, 2010 at 5:22 PM
Edited Jun 23, 2010 at 5:33 PM

I am getting this error with Beta 1.1:

C:\Documents and Settings\barrowsb\My Documents>Powershell ".\PAL.ps1" -Log 'C:\
Documents and Settings\barrowsb\My Documents\PAL_SQLServer_000002.blg' -Threshol
dFile 'C:\Program Files\PAL\PAL v2.0 Beta 1.1\SQLServer.xml' -Interval 'AUTO' -I
sOutputHtml $True -HtmlOutputFileName '[LogFileName]_PAL_ANALYSIS_[DateTimeStamp
].htm' -IsOutputXml $False -XmlOutputFileName '[LogFileName]_PAL_ANALYSIS_[DateT
imeStamp].xml' -AllCounterStats $False
The term '.\PAL.ps1' is not recognized as a cmdlet, function, operable program,
 or script file. Verify the term and try again.
At line:1 char:10
+ .\PAL.ps1  <<<< -Log 'C:\Documents and Settings\barrowsb\My Documents\PAL_SQL
Server_000002.blg' -ThresholdFile 'C:\Program Files\PAL\PAL v2.0 Beta 1.1\SQLSe
rver.xml' -Interval 'AUTO' -IsOutputHtml $True -HtmlOutputFileName '[LogFileNam
e]_PAL_ANALYSIS_[DateTimeStamp].htm' -IsOutputXml $False -XmlOutputFileName '[L
ogFileName]_PAL_ANALYSIS_[DateTimeStamp].xml' -AllCounterStats $False

I've tried adding c:\program files\PAL\PAL v2.0 Beta 1.1\ to my path with the same result

 

Coordinator
Jun 24, 2010 at 9:51 PM

The PowerShell.exe is unable to fine the PAL.ps1 file in your “C:\Documents and Settings\barrowsb\My Documents” directory. If you are running this from the PALWizard.exe (GUI), then make sure that PALWizard.exe and all of the support files (PAL.ps1, *.xml threshold files) are all in the same directory as PALWizard.exe. PALWizard.exe searches for its path, then creates a batch file that changes directory to its location, then executes .\PAL.ps1.

If you are running this from the PowerShell command line, then make sure that your command prompt is set to the PAL installation directory.

Jun 24, 2010 at 11:10 PM
Edited Jun 29, 2010 at 5:26 AM

Hi Clint,

I think it's the GUI that is doing this if you select a counter file that is not in the PAL folder then the batch file that gets created uses the path to that counter file rather than the GUI/Pal install folder.

Example below

C:\Perflogs>C:

C:\Perflogs>cd "C:\Perflogs"

C:\Perflogs>Powershell ".\PAL.ps1" -Log 'C:\Perflogs\Blac
'C:\Program Files\PAL\PAL v2.0 Beta 1.1\SystemOverview.xm
mlOutputFileName '[LogFileName]_PAL_ANALYSIS_[DateTimeSta
Name '[LogFileName]_PAL_ANALYSIS_[DateTimeStamp].xml' -Al
-ThreeGBSwitch $False -SixtyFourBit $False -TotalMemory 4

JonnyG

Jun 25, 2010 at 2:53 PM

I just downloaded the beta1.1 and am seeing the same issue while using PALWizard...

The following is kicked off by the wizard:

Fri 06/25/2010 10:40:52 C:\1\perfmon\gscmamp03ex>Powershell ".\PAL.ps1" -Log 'C:\1\perfmon\gscmamp03ex\GSCMCDP03EXN1_06061900.blg' -
ThresholdFile 'C:\Program Files\PAL\PAL v2.0 Beta 1.1\Exchange.xml' -Interval 'AUTO' -IsOutputHtml $True -HtmlOutputFileName '[LogFi
leName]_PAL_ANALYSIS_[DateTimeStamp].htm' -IsOutputXml $False -XmlOutputFileName '[LogFileName]_PAL_ANALYSIS_[DateTimeStamp].xml' -A
llCounterStats $False
The term '.\PAL.ps1' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of t
he name, or if a path was included, verify that the path is correct and try again.
At line:1 char:10
+ .\PAL.ps1 <<<<  -Log 'C:\1\perfmon\gscmamp03ex\GSCMCDP03EXN1_06061900.blg' -ThresholdFile 'C:\Program Files\PAL\PAL v2.0 Beta 1.1
\Exchange.xml' -Interval 'AUTO' -IsOutputHtml $True -HtmlOutputFileName '[LogFileName]_PAL_ANALYSIS_[DateTimeStamp].htm' -IsOutputX
ml $False -XmlOutputFileName '[LogFileName]_PAL_ANALYSIS_[DateTimeStamp].xml' -AllCounterStats $False
    + CategoryInfo          : ObjectNotFound: (.\PAL.ps1:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

 

 

Coordinator
Jun 28, 2010 at 8:51 AM

The PALWizard.exe is supposed to get it's local working directory and use it. I can't seem to get this problem nailed down unfortunately.

Coordinator
Jun 28, 2010 at 9:05 AM

I can't reproduce this problem. I pointed the PAL wizard to a file in C:\VitalSigns and other directories using the Browse button and it processed them with no problems. Can you give me step by step instructions to what led up to the problem. Thank you.

Jun 28, 2010 at 10:33 AM

Hi Clint,

I seem to be able to reproduce the path problem at will. I wonder if it is OS version specific I'm running PAL on a Windows XP box. I'm betting you are using Win7. If I get a bit of time later today i'll see if I can find a Win 7 machine to test the theory.

JonnyG.

Jun 28, 2010 at 1:42 PM

In terms of the PALWizard, I was able to work around it by manually changing directory to the local working directory. But it seems that it does not change to local working directory properly (I ran this on WS03R2x86 with PS2). Let me try this again on a WS08R2x64 box though...

Fri 06/25/2010 10:40:52 C:\1\perfmon\gscmamp03ex>Powershell ".\PAL.ps1" -Log 'C:\1\perfmon\gscmamp03ex\GSCMCDP03EXN1_06061900.blg' -

Jun 28, 2010 at 5:20 PM

Just did the same on a WS08R2x64 box. All is going fine so far (it is still running but that's the good part :-))

 

BTW I also notice anothe issue with the Exchange 2007 xml - Running on WS03R2x86, it does not show the options to pick number of procs/memory. It is blank. It's looking fine on WS08 though ;-)

Jun 29, 2010 at 8:42 AM

Hi Clint,

Just tested this on a Windows 7 box and its doesn't exhibit the same problem.

JonnyG

 

Dec 21, 2010 at 4:50 PM

Hey guys, I'm also getting this error on a fresh install on version 2 beta 1.2 using the GUI.

This on a windows server 2003 R2 SP2 x86 system.

Sticking the log file into the PAL directory is a successful workaround so it's no big issue. If you want to try and pin the bug down though I'd be willing to help.